企业 已评论

PowerMax REST API 10.0的新功能

2022-9-22 13:11

  【天极网企业频道】Unisphere for PowerMax 10.0已发布,可支持全新的 PowerMax 2500和8500,并在更新的API中提供大量改进。

  所有Dell API的文档均可点击链接查看。PowerMax文档有一个“新增功能”部分,其中包含指向支持页面上最新REST API更改日志的链接。REST API文档直接链接到了UI Help,更易于查找。

  点击如下图所示的导出按钮,该文档还可以OpenAPI.json格式从概览选项卡中下载。

  如旧版本一样,新的API可在新版本的端点下访问:

  API的N-2版本仍可提供对API旧版本的支持。这意味着您可以在运行Unisphere 10.0的服务器上使用9.2或9.1版本的API调用。

  有一个重大变化:运行HyperMax OS 5977和5978的VMAX阵列不可再使用 10.0 REST API进行管理,因Unisphere 10.0不再对其提供支持。

  前端仿真整合(Front End Emulation Convergence)。您也许会问,“这是什么?” 在新的平台上,我们不再提供单独的RDF和FA/SE Director。相反,我们提供统一的仿真,支持可为所需功能启用的端口。这是一种新型的director,缩写为OR(Open Systems and Replication)。对可支持不同协议的OR director 端口,我们需要在列举端口时应用新的筛选器,以便了解哪些端口是为哪种协议启用的。

  另外一个变化是:当列举带有SLO配置API调用的端口时,这些调用不再返回内部和后端的端口。由于用户不能使用这些功能,这样做反而简化了API,总体而言是件好事。如果您确实想要识别系统上的任何后端director和端口,您可以使用系统级director调用来获取该信息。

  对PowerMax 8500和2500而言,创建端口群组现在需要一个指定端口群组协议的附加密钥: SCSI_FC、iSCSI,或者NVMe_TCP。

  本地复制功能的变化

  API的复制资源发生了一些值得注意的变化。我们引入了新的API调用功能,用于对存储群组创建TimeFinder克隆。请阅读《克隆的攻击》 博文,其中详述了克隆可提供的功能。同时,它还解释了为何我们将全新的克隆功能添加到新的PowerMax 8500和2500之中,补充API中已有的SnapVX功能。请注意,克隆API调用功能可兼容现有的PowerMax型号和新阵列。但是,增加的规模和全新的“establish_terminate”功能 (创建一个克隆副本,并在指针就位时立即删除会话) 仅适用于运行PowerMax OS 10的阵列。

  在复制调用功能的幕后,有一些看不见但很有帮助的变化。在以往的版本中,REST调用功能参考 Unisphere对象模型以获取某些信息。现在在Unisphere 10.0中,用于复制的API调用功能可生成解决方案赋能API调用,以确保返回的信息始终与阵列同步。

  API性能的变化

  Unisphere的性能部分有显著改变,主要是帮助新客户更容易使用。我们的开发人员添加了一些辅助方法,帮助您为自己的阵列类型列举性能类别。

  建立了类别列表后,您就可通过类别测量指标助手调用功能,查找每个类别的支持指标列表。您可为全部程序接口或关键程序接口(KPI)指定类型:

  我们性能指标的另一大变化是:现在可获取设备级的诊断统计数据。现在可为一系列的设备或存储群组收集这些数据:每次查询多达100个存储群组或10,000个设备。每次查询仅限一小时的性能数据。这些限制旨在防止开发人员不知不觉地创建高强度的繁重查询(long ranging queries),从而避免影响其他API或UI用户。

  以下是一个调用和有效负载的示例。您可以通过上述的辅助方法,使用卷类别来确定有效类别。与所有性能调用一样,时间戳是以毫秒为单位的EPOCH时间戳。

  面向PowerMax的全新File API接口

  借助与PowerMax File API集成的全新64 位SDNAS平台,我们现在拥有一套全新的端点,用于第0日至第2日的文件对象运行。API为文件运行提供逾 200个API调用。现在可使用UI或REST来完成全部文件运行,从而提供100%的产品覆盖率。下图概述了可在在线文档中浏览的API。

  PyU4V – 面向PowerMax API的软件开发工具包

  在全新的API中,我们还发布了仅与Unisphere 10.0兼容的PyU4V 10.0。由于Unisphere 向后兼容API,您仍可将PyU4V 9.2.1.6 版本与Unisphere 10.0版一同使用。PyU4V以前版本编写的任何脚本都是向前兼容的——如果您没有在使用任何退化函数的话。(PyU4V已为最近的两个版本提供警告消息,通知用户是否需要更改其脚本以实现向前兼容,所以我们希望没有问题!)

  Ansible对PowerMax API 10.0的支持

  更新后的Ansible模块将在9月发布,全面支持新阵列。同时,您可将任意Unisphere服务器更新到10.0版本,现有的Ansible模块将继续运行,前提是您的Ansible服务器已安装了最新的 PyU4V 版本 (9.2.1.6或10.0,适用于PowerMax<=1.8 的Ansible 集合)。(作者:杨明,戴尔科技集团大中华区存储产品市场高级经理)

#+1你赞过了
人已赞
#
分享
查看更多内容

取消

©2020 天极网旗下网站

#
第三方账号登录
X
发布